Compare the Triplets | Practice - Algorithms - Warmup - Compare the Triplets | C code | HackerRank - Helpwalaa - Free IT Updates & Opportunities

New Updates

Compare the Triplets | Practice - Algorithms - Warmup - Compare the Triplets | C code | HackerRank


50 Best College Problem Solution Essay Topics List - EduBirdie.com
------------------------------------------------------------------------------------
Alice and Bob each created one problem for HackerRank. A reviewer rates the two challenges, awarding points on a scale from  to  for three categories: problem clarityoriginality, and difficulty.
We define the rating for Alice's challenge to be the triplet , and the rating for Bob's challenge to be the triplet .
Your task is to find their comparison points by comparing  with  with , and  with .
  • If , then Alice is awarded  point.
  • If , then Bob is awarded  point.
  • If , then neither person receives a point.
Comparison points is the total points a person earned.
Given  and , determine their respective comparison points.
For example,  and . For elements , Bob is awarded a point because . For the equal elements  and , no points are earned. Finally, for elements  so Alice receives a point. Your return array would be  with Alice's score first and Bob's second.
Function Description
Complete the function compareTriplets in the editor below. It must return an array of two integers, the first being Alice's score and the second being Bob's.
compareTriplets has the following parameter(s):
  • a: an array of integers representing Alice's challenge rating
  • b: an array of integers representing Bob's challenge rating
Input Format
The first line contains  space-separated integers, , and , describing the respective values in triplet .
The second line contains  space-separated integers, , and , describing the respective values in triplet .
Constraints
Output Format
Return an array of two integers denoting the respective comparison points earned by Alice and Bob.
Sample Input 0
5 6 7
3 6 10
Sample Output 0
1 1
Explanation 0
In this example:
Now, let's compare each individual score:
  • , so Alice receives  point.
  • , so nobody receives a point.
  • , so Bob receives  point.
Alice's comparison score is , and Bob's comparison score is . Thus, we return the array .
Sample Input 1
17 28 30
99 16 8
Sample Output 1
2 1
Explanation 1
Comparing the  elements,  so Bob receives a point.
Comparing the  and  elements,  and  so Alice receives two points.
The return array is .


Soln -

#include <math.h>

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <assert.h>
#include <limits.h>
#include <stdbool.h>

int main(){
    int a[3],p=0,q=0;
    scanf("%d %d %d",&a[0],&a[1],&a[2]);
    int b[3];
    scanf("%d %d %d",&b[0],&b[1],&b[2]);
    for(int i=0;i<3;i++)
        {
        if(a[i]>b[i])
            p++;
        else if(b[i]>a[i])
            q++;
    }
    printf("%d %d",p,q);
    return 0;
}
-----------------------------------------------------------------

Most Popular